Degraded Call Quality
Resolved·Degraded performance

After continuous monitoring we can confirm that the issue is now resolved.

Sat, Dec 6, 2025, 10:51 PM
(2 weeks ago)
·
Affected components
Platform
Updates

Resolved

After continuous monitoring we can confirm that the issue is now resolved.

Sat, Dec 6, 2025, 10:51 PM

Monitoring

We can confirm that the fix we deployed has worked as expected. We will continue to monitor and provide further updates as required.

Sat, Dec 6, 2025, 07:32 PM(3 hours earlier)

Identified

We have received alerts about call quality issues within our platform. We have found the root cause and have deployed a change. We will continue to monitor and update accordingly.

Sat, Dec 6, 2025, 07:20 PM(11 minutes earlier)
Powered by

Standard support: support@flipcx.com

For emergencies only, call our 24/7 support number:
US: +19143446751
AU: +61721041927
NZ: +6448873695
GB: +442039849869
IE: +35315682891